Merhaba, Ziyaretçi. Lütfen giriş yapın veya üye olun.

Kullanıcı adınızı, parolanızı ve aktif kalma süresini giriniz

  Gelişmiş Arama
insanın içinde varsa, commodore.gen.tr açığa çıkarır bunu.. bir nevi retro olaylarının dolunayıyız.(Arda)
commodore.gen.trGenel KategoriProje27C400/800/160 -> 27C4096 EPROM Programlama Adaptörü
Sayfa: 1 ... 6 7 [8]   Aşağı git
Yazdır
Gönderen Konu: 27C400/800/160 -> 27C4096 EPROM Programlama Adaptörü  (Okunma Sayısı 40554 defa)
0 Üye ve 1 Ziyaretçi konuyu incelemekte.
fort_apocalypse
Uzman
*****
Mesaj Sayısı: 2.513



Üyelik Bilgileri WWW
« Yanıtla #105 : Eylül 05, 2020, 23:47:22 ÖS »

Hort'unu görüyorum ve arttırıyorum.

Bu projeyi kaçıran varsa @ksercan5'in bastırdığı daha gelişmiş modelden 2 tane daha var hala.

https://www.commodore.gen.tr/forum/index.php?topic=18680.0




"Bu da nedir Ney" diyenler için genel bilgi olsun dedim.
Merak edip okuyan çıkar belki.
Logged

ksercan5
Deneyimli
*****
Mesaj Sayısı: 667


80ler candır... Commodore fan since ‘86


Üyelik Bilgileri WWW
« Yanıtla #106 : Eylül 05, 2020, 23:54:48 ÖS »

Daha hotlayacak çok proje var. Pek yakında...
Logged

A500 - Rev6 - 1Mb RAM - GOTEK - Multi-rom
C64C - Multikernel cart - TapeCartSD - Pi1541
C64C - EPYX Fastload
Atari 800XL - Restored
Gameboy DMG-01 - RIPS v2 Upgrade
seco.gen.tr | Satış Sayfam
metaone
Üye
***
Mesaj Sayısı: 121



Üyelik Bilgileri
« Yanıtla #107 : Aralık 29, 2020, 14:23:34 ÖS »

Konuyu ben de biraz hortlatmış olacağım, kusura bakmayın ama EPROM yazma ile ilgili bir sorunum var, paylaşayım istedim.

EPROM burner olarak TL 866II kullanıyorum. Basit C64 EPROM'larını falan okuyup yazıyorum, bir problem çıkmadı şimdiye kadar. Daha yüksek kapasiteli EPROM'lar için de bir ara PCB'sini getirttiğim adaptör yaptım (resim 1), sonra da AliExpress'ten 27C400 EPROM getirttim (resim 2). EPROM'ları önce okuttum (resim 3), sonra da "blank check" yaptım (resim 4). Buraya kadar bir sorun görünmüyor, herşey yazılmaya hazır gibi sanki.

Akabinde 512K boyutunda swapped bir ROM dosyası yükledim ve yazmaya kalktım. Bir anda hata verdi (resim 5). Tekrar okuttuğumda da üstten 4 satır yazılmış, gerisi boş olarak görünüyor. 5 ayrı EPROM'da sil-yaz şeklinde denedim, hep aynı...

Elimde olan Amiga ROM'larına bakayım dedim, adaptörle güzel okuyor, fakat iş yazmaya gelince yazamıyor. Adaptörde mi birşey var, EPROM'larda mı tam anlamadım. EPROM'ları yazma hatası sonrası siliyorum ve "blank check" yapıyorum, problem görünmüyor. Konu ile ilgili tecrübeli arkadaşlardan yardım bekliyorum

Şimdiden teşekkürler.
Mete


*  (161.52 KB, 947x710 - Görüntüleme: 55 kez.)

* 02-EPROM 27C400.jpg (124.89 KB, 395x1008 - Görüntüleme: 51 kez.)

* 03-Read succesfull.JPG (408.07 KB, 1331x994 - Görüntüleme: 58 kez.)

* 04-Blank check succesfull.JPG (52.49 KB, 608x420 - Görüntüleme: 48 kez.)

* 05-Wrilte failed message.JPG (39.02 KB, 605x420 - Görüntüleme: 48 kez.)

* 06-Read after fail.JPG (434.17 KB, 1332x999 - Görüntüleme: 55 kez.)
Logged

Commodore 64 ve 64C, 1541-II, SD2IEC, PiZero1541, FCIII, JiffyDOS
Amiga 1200, ACA1233n 26 MHz 128MB, GOTEK Floppy, 16Gb CF HD, PCMCIA CF
Amiga 500 1MB, GOTEK Floppy
Sinclair Spectrum 48K, DivMMC Pro
fort_apocalypse
Uzman
*****
Mesaj Sayısı: 2.513



Üyelik Bilgileri WWW
« Yanıtla #108 : Aralık 29, 2020, 14:48:00 ÖS »

Eğer adaptör dolu epromu doğru okuyorsa yüzde 99 adaptör sağlamdır.

Benim tahminime göre 2 ihtimal var

1 Programlama algoritması sizin kullandığınız marka ile uymlu değildir, başka markanın aynı modelini seçerek deneyebilirsiniz. Puls delay süresini 100us deneyebilirsiniz.

2 Bu epromlar artık üretilmiyor, genelikle kullanılmış "çıkma" epromdur ve arızalıdır. (Gene de epromu atmayın, belki başka model programlayıcıda programlanabilir.
« Son Düzenleme: Aralık 29, 2020, 14:50:55 ÖS Gönderen: fort_apocalypse » Logged

haydar_abi
Uzman
*****
Mesaj Sayısı: 1.089


İlla ki Amiga


Üyelik Bilgileri
« Yanıtla #109 : Aralık 29, 2020, 15:45:38 ÖS »

HOLTEK 27C4096 seçerek dene, voltajlar biraz daha düşük oluyor. Aynı adaptörü kullanıyorum. Bir defa sıkıntı oldu. lehimin biri tam tutmamıştı. Program olarak da minipro 6,85 kullanıyorum.
Logged

Amiga fanatiği.... 
Amigalıktan çıkmış Amigalar....

Amiga 1200 Vampire V1200 + HDMI + 64 GB CF HDD + PCMCIA CFDisk Adapter 32 GB CF +  Gotek
LG 24MA53 TVMonitör
Amiga 500 Plus +8 MB RAM+16 GB CF
Amiga 500 + 2 MB RAM Kart + Internal GOTEK + 4GB CF HDD
Casper M989A Monitör
metaone
Üye
***
Mesaj Sayısı: 121



Üyelik Bilgileri
« Yanıtla #110 : Aralık 29, 2020, 18:14:06 ÖS »

@fort_apolcalypse @haydar_abi öncelikle teşekkürler.

27C4096 modeli ile ilgili 7 marka denedim. İçlerinde Fujitsu ile Holtek %1,76'ya kadar yazabildi, sonra hata ile durdu. Diğerlerinde yukarıda anlattığım aynı problemle karşılaştım. 9 adet Eprom'um var, sırayla denedim ama olmadı. Okumada problem gözükmediğine göre ya EPROM'lar üzerinde yazdığı gibi 1991 model ve fazlasıyla eski ya da belki de bozuklar, bilemedim. Sipariş ettiğim başka EPROM'lar var, gelince bir de onlara deneyeceğim. Bunlardan bir sonuç çıkaramadım. Tekrar teşekkürler.
Logged

Commodore 64 ve 64C, 1541-II, SD2IEC, PiZero1541, FCIII, JiffyDOS
Amiga 1200, ACA1233n 26 MHz 128MB, GOTEK Floppy, 16Gb CF HD, PCMCIA CF
Amiga 500 1MB, GOTEK Floppy
Sinclair Spectrum 48K, DivMMC Pro
Voltron
Uzman
*****
Mesaj Sayısı: 1.746



Üyelik Bilgileri
« Yanıtla #111 : Aralık 30, 2020, 12:18:54 ÖS »

@fort_apolcalypse @haydar_abi öncelikle teşekkürler.

27C4096 modeli ile ilgili 7 marka denedim. İçlerinde Fujitsu ile Holtek %1,76'ya kadar yazabildi, sonra hata ile durdu. Diğerlerinde yukarıda anlattığım aynı problemle karşılaştım. 9 adet Eprom'um var, sırayla denedim ama olmadı. Okumada problem gözükmediğine göre ya EPROM'lar üzerinde yazdığı gibi 1991 model ve fazlasıyla eski ya da belki de bozuklar, bilemedim. Sipariş ettiğim başka EPROM'lar var, gelince bir de onlara deneyeceğim. Bunlardan bir sonuç çıkaramadım. Tekrar teşekkürler.

TL866 ile kullandığın usb kabloyu bir değiştirmeyi deneyebilirsin belki. Benzer bir durumla karşılaştım, 27C256, atmega88 okuyor ama programlayamıyordum. Programlarken progress interval çeyreğe gelmeden kesiliyordu. Araştırdım biraz, çakma cihazlar yapabiliyormuş bunu ama çakma cihaz olmayan başka birinin de başına gelmiş ve kabloyu değiştirince düzelmiş. Ben de aynısını yaptım başka bir kablo ile deneyince yazım tamamlandı sorunsuz. Kabloyu da imha ettim çünkü benim MIDI klavyelerimde de soruna yol açan oymuş.
Logged

1 Koli Yumurta
1 Lt Zeytinyağı
2 Kg Şeker
1 Kg Çay
Şampuan
1 Koli Peçete
Domestos
ksercan5
Deneyimli
*****
Mesaj Sayısı: 667


80ler candır... Commodore fan since ‘86


Üyelik Bilgileri WWW
« Yanıtla #112 : Aralık 30, 2020, 12:43:57 ÖS »

Bir de usb hub yerine direk bilgisayara bağlamak fayda sağlayabilir. 
Logged

A500 - Rev6 - 1Mb RAM - GOTEK - Multi-rom
C64C - Multikernel cart - TapeCartSD - Pi1541
C64C - EPYX Fastload
Atari 800XL - Restored
Gameboy DMG-01 - RIPS v2 Upgrade
seco.gen.tr | Satış Sayfam
metaone
Üye
***
Mesaj Sayısı: 121



Üyelik Bilgileri
« Yanıtla #113 : Aralık 30, 2020, 15:15:37 ÖS »

@Voltron USB kabloyu değiştirdim, hatta daha kaliteli olduğunu düşündüğüm bir kabloyu bağladım, ama nafile.

@ksercan5 hocam EPROM programlayıcısını doğrudan bağlıyorum bilgisayara, hub yok arada.

Ya EPROM'ların tümünde aynı hata/uyumsuzluk var, ya da adaptörde bir sorun olabilir (okuma yapsa da). Bir adaptör daha yapacağım galiba, bundaki hatayı bulana kadar. Haydar Abi de sağolsun EPROM'lara bakacak.
Logged

Commodore 64 ve 64C, 1541-II, SD2IEC, PiZero1541, FCIII, JiffyDOS
Amiga 1200, ACA1233n 26 MHz 128MB, GOTEK Floppy, 16Gb CF HD, PCMCIA CF
Amiga 500 1MB, GOTEK Floppy
Sinclair Spectrum 48K, DivMMC Pro
metaone
Üye
***
Mesaj Sayısı: 121



Üyelik Bilgileri
« Yanıtla #114 : Aralık 30, 2020, 16:45:28 ÖS »

Haydar Abi EPROM’lara baktı, sorun gözükmüyor. O zaman sıkıntı adaptörde büyük ihtimalle. Yaptığım adaptördeki hatayı bulmak yerine daha dikkatli şekilde yeni yapacağım, gelişmeleri bildiririm.
Logged

Commodore 64 ve 64C, 1541-II, SD2IEC, PiZero1541, FCIII, JiffyDOS
Amiga 1200, ACA1233n 26 MHz 128MB, GOTEK Floppy, 16Gb CF HD, PCMCIA CF
Amiga 500 1MB, GOTEK Floppy
Sinclair Spectrum 48K, DivMMC Pro
metaone
Üye
***
Mesaj Sayısı: 121



Üyelik Bilgileri
« Yanıtla #115 : Ocak 05, 2021, 14:19:12 ÖS »

Son durumu bildireyim istedim.

Hardar Hocamın (@haydar_abi) EPROM'ları kontrol edip sağlam olduklarını onaylaması sonrası kendime yeni adaptör yaptım ve bu sefer çalıştı... Muhtemelen bir yerde lehim hatası yapmışım ilkinde.

@haydar_abi @fort_apocalypse @Voltron @ksercan5 destekleriniz için teşekkürler.

Logged

Commodore 64 ve 64C, 1541-II, SD2IEC, PiZero1541, FCIII, JiffyDOS
Amiga 1200, ACA1233n 26 MHz 128MB, GOTEK Floppy, 16Gb CF HD, PCMCIA CF
Amiga 500 1MB, GOTEK Floppy
Sinclair Spectrum 48K, DivMMC Pro
Sayfa: 1 ... 6 7 [8]   Yukarı git
Yazdır
Gitmek istediğiniz yer: